Problema com WiFi no Ubuntu 16.04

Atualização 15/07/2016: meu WiFi parou de funcionar após o último update do 16.04. Eu já tinha executado o procedimento abaixo e achei que dessa vez o problema era outro. Após alguns dias pesquisando sem sucesso, entendi que o último update atualizou o pacote linux-firmware. Resumindo, tive que executar novamente o procedimento abaixo e tudo voltou a funcionar. Espera-se que em breve os repositórios do Ubuntu reflitam as modificações implementadas na versão não-oficial de drivers.


Após a instalação do Ubuntu 16.04 num Dell Inspiron 5557 o WiFi não funcionou automaticamente.

Se você está passando por problema semelhante, o primeiro passo é checar o modelo de sua placa wireless. Isso pode ser feito pelo comando:

lshw -C network

No meu caso a placa é:

description: Wireless interface
product: QCA6174 802.11ac Wireless Network Adapter
vendor: Qualcomm Atheros

Se essa não é sua placa, os comandos abaixo não servirão para você, ainda que a solução possa lhe servir de inspiração.

O problema com a placa QCA6174 já é conhecido na comunidade e uma busca no Google com o nome da placa e problemas de conexão retornará alguns posts envolvendo a instalação de um firmware não-oficial ainda não disponível nos repositórios.

Segue abaixo a sequência de comandos que deve ser executada. Note que, para que esta solução funcione, você deverá estar conectado à Internet (provavelmente, via cabo). É necessário reiniciar o computador após o procedimento.

Se você está enfrentando o mesmo problema, espero que a dica sirva para você também.


sudo mkdir -p /lib/firmware/ath10k/QCA6174/hw3.0/

sudo rm /lib/firmware/ath10k/QCA6174/hw3.0/* 2> /dev/null

sudo wget -O /lib/firmware/ath10k/QCA6174/hw3.0/board.bin https://github.com/FireWalkerX/ath10k-firmware/blob/7e56cbb94182a2fdab110cf5bfeded8fd1d44d30/QCA6174/hw3.0/board-2.bin?raw=true

sudo wget -O /lib/firmware/ath10k/QCA6174/hw3.0/firmware-4.bin https://github.com/FireWalkerX/ath10k-firmware/blob/7e56cbb94182a2fdab110cf5bfeded8fd1d44d30/QCA6174/hw3.0/firmware-4.bin_WLAN.RM.2.0-00180-QCARMSWPZ-1?raw=true

sudo chmod +x /lib/firmware/ath10k/QCA6174/hw3.0/*


A solução está descrita no post #22 do seguinte link:

https://bugs.launchpad.net/ubuntu/+source/linux-firmware/+bug/1520343?comments=all

Anúncios

18 ideias sobre “Problema com WiFi no Ubuntu 16.04

  1. Michael Meneses

    Meu amigo, não poderia sair daqui sem deixar meu comentário. Tive o mesmo problema com o Dell 7559. Agora com essa atualização do Ubuntu 16.04 o Wifi “morreu”. Dessa vez foi muito mais fácil encontrar a solução. Abraços.

    Curtido por 1 pessoa

    Resposta
    1. xaoquadrado Autor do post

      Vou ficar te devendo essa resposta. No Debian tudo pode ser mais complicado… Se descobrí-la, volte para compartilhar. Pelo visto este problema está atingindo bastante gente.

      Curtir

      Resposta
  2. Daniel

    Cara,

    Muito obrigado mesmo!! Comprei o mesmo notebook do post, e ele veio com uma versão inferior do Ubuntu. Na hora que atualizei para o 16.04 tinha parado de funcionar wi-fi. Fiz os comandos ali e resolveu!

    Abraço!

    Curtir

    Resposta
  3. Weber

    Tenho uma máquina igual a sua e estou com problemas no drive da nVidia. Consigo instalar pelo apt-get, mas não há a opção de escolher qual utilizar como havia na versão do ubuntu que veio da Dell.

    Curtido por 1 pessoa

    Resposta
  4. Pingback: Como configurar/instalar a interface Wi-fi Atheros QCA6174 no Ubuntu/LinuxMint e derivados! | Blog SempreUPdate GNU/Linux

Deixe seu comentário

Preencha os seus dados abaixo ou clique em um ícone para log in:

Logotipo do WordPress.com

Você está comentando utilizando sua conta WordPress.com. Sair / Alterar )

Imagem do Twitter

Você está comentando utilizando sua conta Twitter. Sair / Alterar )

Foto do Facebook

Você está comentando utilizando sua conta Facebook. Sair / Alterar )

Foto do Google+

Você está comentando utilizando sua conta Google+. Sair / Alterar )

Conectando a %s